Не грузится Orange Pi Plus 2E


  • 0

    Пытаюсь загрузить Orange Pi Plus 2E и она виснет на разных этапах загрузки. Плата с начала эксплуатации ни разу успешно не загрузилась.
    Процесс загрузки мониторю через UART.

    Я пытался загрузить первоначально зашитую OC, которая по умолчанию должна быть на eMMC, а также разные версии Armbian, Lubuntu и Debian: десктопные и серверные.
    Результат один и тот же: плата начинает грузиться, идет лог в терминале, а потом примерно на 4-й секунде зависает, причем на совершенно разных этапах, даже если используется одна и та же ОС на одной и той же SD карте. Я ждал по 15 минут, в надежде, что отвиснет - не помогло.
    Логи мог бы привести, но во-первых они длинные, а во-вторых, как я уже упомянул выше - виснет в разных местах, то есть по месту зависания вряд ли можно сделать вывод о той или иной ошибке.

    Я пробовал 3 разных SD карты, все работали безглючно в других местах. Одна из карт использовалась для работы с Odroid C2. Он с неё нормально грузится и работает (образ естественно другой, просто упоминаю, чтобы было понятно, что карта точно хорошая и быстрая)

    При загрузке с emmc горит красный диод, на экране монитора только лого Allwinner H3.
    При загрузке с SD экран черный, горит зеленый диод.
    Эти внешние признаки не зависят от того, подключен UART или нет.

    Также при загрузке есть надпись "Press any key to stop autoload"
    Если я нажимаю любую клавишу, то загрузка, естественно останавливается, и я могу вводить команды, на которые плата отвечает. Только что в этой консоли делать и можно ли с её помощью понять причину глюка - я не знаю.

    Вычитал, что Orange PI очень чувствительны к питанию: провод использую тот, который пришел с картой, в качестве адаптера пробовал брендовые Samsung 2A, Apple 2.1A и быструю зарядку от Oukitel. Также пробовал подключить к лабораторному БП, он показывает ток 0.5А. 
    Еще пробовал подключать к блоку батарей через конвертер напряжения, купленный на алиэкспрессе, у него вообще по спецификации максимальный ток 4,5 А. И тем более, что вообще использование планировалось именно от батарейного блока после разработки.
    Вычитал даже на форуме Armbian, что у одного человека была подобная проблема и он её вылечил, подключив питание одновременно через разъем питания и с другого источника через GPIO. Но мне тоже не помогло.

    Кстати опять же, от всех протестированных источников питания Odroid C2 прекрасно работает без глюков.

    Может у кого есть версии?



  • 1

    я б советовал бьі вернуть комп в магазин и поменять или вернуть деньги



  • 2

    @Hamulus Да, вы перечислили наверное все, что можно было бы попробовать сделать с ней, похоже на дохлую электронику.
    Единственное что я мог бы еще посоветовать - запитайте плату посредством GPIO, внимательно посмотрите распиновку, отсчитывайте от пина с пометкой (стрелочка), распиновка не на всех Orange Pi одинакова, на части плат гребенка банально перевернута вверх тормашками.



  • 3

    @Hamulus мне кажется что на каком-то компоненте с bga пайкой есть треснутый шарик который при нагревании отходит, после чего все виснет, если вернуть в магазин не возможно на крайний случай надо прогреть все компоненты феном



  • 4

    у меня в этом опыта нет, хотя фен есть:)
    до какой температуры и сколько времени надо прогревать?
    стоит ли греть все компоненты с BGA (т.е. процессор, память и emmc) или что-то можно точно не греть?
    правильно ли я понимаю, что надо остальное всё экранировать, чтобы SMD не уплыли?
    есть ли шанс перегреть чипы? (хотя терять особо нечего, плата всё равно глючная)



  • 5

    сказать что греть конкретно не могу, попробуй сначала проц, потом все по очереди, после каждого прогревания включать и проверять как работает
    перегреть шанс есть всегда, я б посоветовал погреть сначала что то не рабочее и ненужное, например видео карту дохлую
    постав поток на минимум, температуру 340, все что не будешь греть замотай пищевой фольгой, оставь только окно для детальки, греешь, переодически тикаешь легонько в детальку пинцетом или чем то металлическим, когда деталька начнет шевелится легонько придай небольшое смещение в одной оси(Х) потом в другой оси(Y), так пару раз, потом ждёшь когда комп остынет полностью, включаешь проверяешь



  • 6

    легонько это так чтобы когда ты отпускаешь пинцет деталька вернулась назад на место сама



  • 7

    в итоге плата заработала отлично с оригинальным адаптером на 3A
    это ж что за требования к питанию такие?:))

    и самое главное - как её питать от батареи? как я писал выше, конвертер напряжения на 4,5А тоже её не “завел”





Похоже, подключение к PiBoard было разорвано, подождите, пока мы пытаемся восстановить соединение.